Home Forums Troubleshooting Iolite upgrade problems

This topic contains 9 replies, has 5 voices, and was last updated by  Jimikova 4 months, 2 weeks ago.

  • Creator
    Topic
  • #6717

    Robert Thompson
    Participant

    When I tried to upgrade to v.3.4 this morning, the upgrade led to an error window, and now I cannot access Iolite at all when I open Igor. Can anyone please help me restore the old version of Iolite? Thanks.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Author
    Replies
  • #6718

    Tomas Næraa
    Participant

    I have a similar problem. After performing the update to v3.4 Iolite stopped working. I think the problem in my case is that I did not remove the VisualAge DRS before updating.
    I have tryed to re-install my v3.32 but it also does not run.

    #6721

    Hi,

    Robert, could you please describe the error you encountered when upgrading iolite? Was it an incomplete upgrade due to the presence of custom DRS as for Tomas?

    Tomas, VisualAge is a custom DRS and most likely the cause of the updater crash. What the updater did, before trying to close the custom DRS, was to create two new folders within your iolite_v3.32 folder, the Version_3.4 and Version_3.32 folders. The Version_3.32 folder contains a backup of the default version3.32, and Version_3.4 folder one of the new version.
    To fix the issue of an incomplete upgrade (due to the presence of an unrecognised DRS) please close igor, and then copy all the files within Version_3.4>v3.4_Data Reduction schemes folder into your Data Reduction Schemes folder, and copy all the files within Version_3.4>v3.4_Global Procedures folder, except the Webupdater.ipf, into your Global Procedures folder. Any files of the same name contained in the Data Reduction Schemes and Global Procedures folders should be overwritten.
    The new Iolite version should work without issues after restarting igor .

    Best regards,
    Tephy

    #6722

    Tomas Næraa
    Participant

    It solved my problem, thank a lot!

    #6747

    Robert Thompson
    Participant

    Tephy-

    I did not have any custom DRS installed, but I was able to have Bence TeamViewer into my system and correct the problem. Thank you for responding.

    #6840

    LStockli
    Participant

    Dear Forum,

    I, too, am experiencing a problem updating Iolite. We had been running Iolite 3.1 (with VisualAge DRS). I first updated to Iolite 3.22, which seemed to work fine. The extra DRS was not transferred to the new Iolite 3.22 folder. Then I ran Iolite 3.22 and immediately tried to upgrade to Iolite 3.4, but got this error:

    Error in Execute: IgorStartOrNewHook(“iolite”)

    I followed the directions for copying files posted by Tephy (above), and that worked. Now I can run Iolite 3.4, but the relevant files are now in the IgorPro6 User Files > iolite_v3.32 folder, which doesn’t seem ideal. In other words, no folder for iolite v4 was created directly in the IgorPro6 User Files folder, it can only be accessed by going through IgorPro6 User Files > iolite_v3.32> folder.

    I’m unclear on how/where the files are being referenced. The big problem is that I cannot figure out where to copy the VisualAge DRS file to get it to load properly now. I tried installing VisualAge, and get the message that it has installed properly, but when I reopen Iolite the VisualAge menu does not appear, and if I choose VisualAge as the DRS, I get this error:

    Error in VisualAgeDRS.ipf: RunActiveDRS

    Sorry for the long-winded posting,
    Lisa

    #6849

    Hi Lisa,

    If the upgrade was successful, please feel free to manually rename the name of the iolite folder from iolite_v3.32 to iolite_v3.4 to avoid any confusion.

    The Global Procedures and Data Reduction Schemes folders (without any prefix) are the ones linked to igor.
    For VizuaAge installation instructions visit http://www.japetrus.net/va/

    If the issue continues, send us an email to support@iolite-software.com

    Tephy

    #6860

    Jimikova
    Participant

    Hello to all,

    I am also experiencing problem with VisualAge as Lisa. I have installed Iolite_v3.4 to brand new computer as described and it is working fine, but when I try to install VisualAge (as decriber in Joe Petrus manual) I get the message: “VisualAge has been sucsesfully installed. To use it you will need to restart Igor”, but when I restart Igor there is only Iolite menu and the VisualAge menu does not appear. I do not even have VisualAge in between my DRS schemes.
    From my experience maybe it is not connected to upgrade. Any ideas what else I can try, please?

    #6864

    LStockli
    Participant

    I finally did get VisualAge to work after updating to Iolite3.4. I had forgotten the trick of copying the VisualAge.ipf, VisualAgeCalc.ipf, and the VisualAgePlotting.ipf files to the Add ons folder. Once I did that, VisualAge loaded fine when I opened Iolite.

    regards,
    Lisa Stockli

    Manager LA-ICP facility
    Univ. of Texas at Austin

    #6865

    Jimikova
    Participant

    Hello Lisa,

    I have solved it by simillar way not knowing this trick. I got the same results by directly copying the VisualAge.ipf, VisualAgeCalc.ipf, and the VisualAgePlotting.ipf files to the Global procedures folder and VisualAgeDRS.ipf into Data Reduction Schemes folder.

    Best regards

    Jitka

Viewing 9 replies - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.